Go Back   Winnipesaukee Forum > Winnipesaukee Forums > Boating
Home Forums Gallery Blogs YouTube Channel Classifieds Links Calendar Register FAQDonate Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 08-06-2021, 07:00 AM   #1
Senter Cove Guy
Senior Member
 
Senter Cove Guy's Avatar
 
Join Date: Apr 2004
Posts: 577
Thanks: 252
Thanked 398 Times in 127 Posts
Default Humminbird Unit Problems

I have a Humminbird 998 c SI unit that was bought in 2012. It has stopped displaying GPS position data. I suspect that the antenna and/or antenna wire has gone bad. I would like to test my unit on someone else's boat before spending the money for a new antenna. Please private message me if you have a Humminbird installed in your boat where we could do this? Thanks.
__________________
Lake Winni - The only place I want to be during the summer.
Senter Cove Guy is offline   Reply With Quote
Old 08-06-2021, 06:06 PM   #2
Charlie T
Senior Member
 
Join Date: Apr 2004
Posts: 272
Thanks: 199
Thanked 147 Times in 67 Posts
Default

Quote:
Originally Posted by Senter Cove Guy View Post
I have a Humminbird 998 c SI unit that was bought in 2012. It has stopped displaying GPS position data. I suspect that the antenna and/or antenna wire has gone bad. I would like to test my unit on someone else's boat before spending the money for a new antenna. Please private message me if you have a Humminbird installed in your boat where we could do this? Thanks.
I too have an older GPS. A couple of years ago it would not operate properly at the beginning of the season. A quick google search told me it was a common issue as the internal battery that keeps the memory alive had finally given up the ship after about 10 years. I opened the unit up, identified the battery and swapped it out with a new unit. This was a soldered in battery but being an electronics bench tech that wasn't an significant issue for me to resolve. I had to perform a complete initialization set up as if the unit was brand new but the battery fixed the issue.

YMMV but its worth a shot.
Charlie T
Charlie T is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:35 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

This page was generated in 0.70230 seconds