Go Back   Winnipesaukee Forum > Winnipesaukee Forums > General Discussion
Home Forums Gallery Blogs YouTube Channel Classifieds Links Calendar Register FAQDonate Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-18-2019, 01:47 PM   #1
Slickcraft
Senior Member
 
Join Date: Mar 2008
Location: Welch Island and West Alton
Posts: 2,550
Thanks: 808
Thanked 1,405 Times in 644 Posts
Default Another moment at Glendale

Ramp to barge broke when backing a 14 wheeler up to the barge with a load of ledgepack. The excaavator did unload most of the ledgepack to the barge.

With aid of one wrecker crane lifting back of truck and another pulling they got it back on land. When we left there was a bent steel plate against a 3rd rear axle tire preventing driving away. New truck with less that 100 miles.
Attached Images
   
Slickcraft is offline   Reply With Quote
Old 07-18-2019, 02:02 PM   #2
Hillcountry
Senior Member
 
Join Date: Apr 2016
Location: In the hills
Posts: 1,657
Thanks: 850
Thanked 410 Times in 263 Posts
Default

Heavy equipment...always a chance for a disaster!
Hillcountry is offline   Reply With Quote
Old 07-18-2019, 02:07 PM   #3
joey2665
Senior Member
 
joey2665's Avatar
 
Join Date: Sep 2008
Location: Meredith Bay & LI, NY
Posts: 2,171
Thanks: 450
Thanked 546 Times in 369 Posts
Default

Did the ramp break or it looks like the tracks were spread too far apart. If I owned that truck I would not be happy with the driver nor the barge owner. Looks to me like this could have been avoided, speaking as someone how has driven and owned a fleet of dump and ready mix trucks
joey2665 is online now   Reply With Quote
Old 07-18-2019, 02:46 PM   #4
Slickcraft
Senior Member
 
Join Date: Mar 2008
Location: Welch Island and West Alton
Posts: 2,550
Thanks: 808
Thanked 1,405 Times in 644 Posts
Default

Quote:
Originally Posted by joey2665 View Post
Did the ramp break or it looks like the tracks were spread too far apart. If I owned that truck I would not be happy with the driver nor the barge owner. Looks to me like this could have been avoided, speaking as someone how has driven and owned a fleet of dump and ready mix trucks
The ramp broke
Attached Images
 
Slickcraft is offline   Reply With Quote
Old 07-18-2019, 03:19 PM   #5
Phantom
Senior Member
 
Phantom's Avatar
 
Join Date: Jul 2005
Location: Hudson, Ma / Gilford
Posts: 1,764
Thanks: 340
Thanked 518 Times in 295 Posts
Default

Then Northland is gonna certainly get an earful from Shane's …… your pic may come in handy !!
__________________
A bad day on the Big Lake (although I've never had one) - Still beats a day at the office!!
Phantom is offline   Reply With Quote
Sponsored Links
Old 07-18-2019, 03:26 PM   #6
Mr. V
Senior Member
 
Mr. V's Avatar
 
Join Date: Jun 2004
Location: the left coast (Portland)and West Alton
Posts: 803
Thanks: 14
Thanked 88 Times in 63 Posts
Default

Quote:
Originally Posted by Phantom View Post
Then Northland is gonna certainly get an earful from Shane's your pic may come in handy !!.
The reality, of course, is that their INSURER will "get an earful."
__________________
basking in the benign indifference of the universe
Mr. V is offline   Reply With Quote
Old 07-18-2019, 03:56 PM   #7
joey2665
Senior Member
 
joey2665's Avatar
 
Join Date: Sep 2008
Location: Meredith Bay & LI, NY
Posts: 2,171
Thanks: 450
Thanked 546 Times in 369 Posts
Default

Quote:
Originally Posted by Slickcraft View Post
The ramp broke
Thanks Slickcraft. Can't tell from the picture but looks like the bolt sheared. Do you know what the damage was to the dump truck?
joey2665 is online now   Reply With Quote
Old 07-18-2019, 04:22 PM   #8
ishoot308
Senior Member
 
Join Date: Feb 2008
Location: Gilford, NH / Welch Island
Posts: 4,307
Thanks: 1,532
Thanked 3,105 Times in 1,197 Posts
Default

Quote:
Originally Posted by joey2665 View Post
Do you know what the damage was to the dump truck?
Busted tail light, bent trailer hitch and plate... I know Shane well, he's a good guy does great work. This could of been a lot worse!!...Truck has 5800 miles on it, purchased last October... Shane told me hitch pin broke on barge ramp causing issue.

Dan
__________________
It's Always Sunny On Welch Island!!
ishoot308 is offline   Reply With Quote
The Following User Says Thank You to ishoot308 For This Useful Post:
stingray (07-18-2019)
Old 07-18-2019, 04:33 PM   #9
joey2665
Senior Member
 
joey2665's Avatar
 
Join Date: Sep 2008
Location: Meredith Bay & LI, NY
Posts: 2,171
Thanks: 450
Thanked 546 Times in 369 Posts
Default

Quote:
Originally Posted by ishoot308 View Post
Busted tail light, bent trailer hitch and plate... I know Shane well, he's a good guy does great work. This could of been a lot worse!!...Truck has 5800 miles on it, purchased last October... Shane told me hitch pin broke on barge ramp causing issue.

Dan
Thanks Dan. Trust me over the years I have had similar and worse incidents with my trucks.

Not too bad on the damage. Luckily nothing happened to the drop down axel.


Sent from my iPhone using Winnipesaukee Forum mobile app
joey2665 is online now   Reply With Quote
Old 07-19-2019, 08:45 AM   #10
brk-lnt
Senior Member
 
brk-lnt's Avatar
 
Join Date: Aug 2007
Location: South Down Shores
Posts: 1,818
Thanks: 487
Thanked 526 Times in 301 Posts
Default

Quote:
Originally Posted by ishoot308 View Post
Busted tail light, bent trailer hitch and plate... I know Shane well, he's a good guy does great work. This could of been a lot worse!!...Truck has 5800 miles on it, purchased last October... Shane told me hitch pin broke on barge ramp causing issue.

Dan
Not that I doubt what you were told, but from the pic posted I don't see any broken hitch pins, it looks more like the weld on the bracket to the ramp gave out.
__________________
[insert witty phrase here]
brk-lnt is offline   Reply With Quote
The Following User Says Thank You to brk-lnt For This Useful Post:
jbolty (07-19-2019)
Old 07-19-2019, 09:21 AM   #11
ishoot308
Senior Member
 
Join Date: Feb 2008
Location: Gilford, NH / Welch Island
Posts: 4,307
Thanks: 1,532
Thanked 3,105 Times in 1,197 Posts
Default

Quote:
Originally Posted by brk-lnt View Post
Not that I doubt what you were told, but from the pic posted I don't see any broken hitch pins, it looks more like the weld on the bracket to the ramp gave out.
Hi brk!

You are correct...I should have been more precise and said "hitch pin bracket"...either way the ramp gave way causing the issue. It was definitely not driver error...

Dan
__________________
It's Always Sunny On Welch Island!!
ishoot308 is offline   Reply With Quote
The Following User Says Thank You to ishoot308 For This Useful Post:
brk-lnt (07-22-2019)
Old 07-21-2019, 07:15 AM   #12
Tank151
Senior Member
 
Join Date: Mar 2006
Location: Boston, MA & Laconia, NH
Posts: 129
Thanks: 7
Thanked 10 Times in 9 Posts
Default

Thank god nobody was injured!
Tank151 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:55 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

This page was generated in 0.08761 seconds