Go Back   Winnipesaukee Forum > Winnipesaukee Forums > Boating
Home Forums Gallery Blogs YouTube Channel Classifieds Links Calendar Register FAQDonate Members List Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-10-2019, 10:01 AM   #1
LaFuga
Junior Member
 
LaFuga's Avatar
 
Join Date: Jun 2019
Location: berwick
Posts: 14
Thanks: 5
Thanked 0 Times in 0 Posts
Unhappy finally got to enjoy my sea ray!

Hey guys, not sure if you remember me posting about my stalling issue with my 74 sea ray this summer after being a first time boat owner. The boat has a 2003 driveline in it...305 mercruiser mpi. After going to a local marine and spending 2500$+ for diag, FULL tune up i.e. plugs, cap and rotor, and coil. Then new fuel pump, then messing with lines etc and more diag....after asking the mechanic if he checked my fuel tank where the boat had been sitting for 2yrs, and he said he did, and looked inside with a camera as well...no problems there he said.....then he had decided that the boat was vapor locking. He even lent me his 6gal fuel tank to switch over to if the boat stalled while out in the lake. After 7 or more times of stalling and using his tank 3-4 times and the boat running perfect with his tank. With the theory of vapor locking, he ordered and installed a 'boost pump' which was another 900$ bill I didnt pay when i took it the last time in...i asked if i could use the boat 3-4 times before i paid the bill to make sure it was finally fixed....they said I could so I took it out and yes....it still stalled....so before I just gave up, I decided to replace the fuel tank myself. Ive never done one before but it looked simple enough...so i removed the tank and looked inside just to find it FULL OF CRAP! I ordered another larger tank and installed it....guess what? boat ran mint for the last 6 or 7 times i took it out...a novice and def not a mechanic...i fixed the boat myself and have not gone back to that marina. mind you i did bring the old tank back there once i pulled it out and the guy said..'wow, that stuff must have gotton loose the last few weeks!' I said politely ...."well, your camera must not have been working the day you put it in my tank" ....the guy gives me no apologies, no admitting that he wasted my money and summer not looking at what he should have seen from the first inspection he had on the boat when i spent over 1000$ to have it gone thew after i bought it. So one of the last words I said to him the day i showed him the tank full of crap is "you should take out this boost pump because I dont wana owe the marina a dollar...clearly the new tank i put in fixed it" he said, thats fine, we'll take it out when you bring it back for the winterization in the fall. I said "ok, see you in the fall". I have no intentions of bringing that boat back to that marina...I mean, if he had admitted to not diagnosing it correctly or at least saying to me that they would winterize it for free due to all the money i gave them to fix it and it never being fixed by them, I would bring it back...finding a new marina to winterize it and wrap it. all done... anyone think im out of line by not bringing it back even tho I told him I would??
LaFuga is offline   Reply With Quote
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 05:56 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

This page was generated in 0.34721 seconds